bookweevil

7 March 2009

button text disappearing in firefox

Filed under: useful — bookweevil @ 12:24 am

If you fiddle around with some firefox settings while developing extensions, this can result in HTML buttons no longer having any text in them.

In Stu’s post here, “No button text in Firefox”, he suggests you ensure that the following lines are uncommented in prefs.js in your profile [or you could set the options to false using about:config]:

user_pref("nglayout.debug.disable_xul_cache", true);
user_pref("nglayout.debug.disable_xul_fastload", true)
user_pref("nglayout.debug.enable_xbl_forms", true)

Experimentation reveals it’s the third one, .enable_xbl_forms, which causes the problem – but I’m not sure how it got set. (An article at the mozilla developer centre, “Setting up extension development environment“, recommends enabling the first of these, but not the others.) It’s possible some developer add-on enabled it, or that I just clicked on it accidentally in about:config.

Advertisements

1 Comment »

  1. Hi there, glad my post came in useful for you. :)

    It is a bit of an unusual thing to happen.

    Comment by Stuart — 7 March 2009 @ 12:47 am


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Create a free website or blog at WordPress.com.

%d bloggers like this: